Thread: Configuring XA Datasource in Jboss WildFly server

Forum : Miscellaneous   21 Mar, 2017 04:00
User Image
Kewal4089

Newbie

Joined: 20 Apr, 2017

Points: 100

Threads: 1

Posts: 2

Configuring XA Datasource in Jboss WildFly server

| Quote Date : 21 Mar, 2017    Views:4322    

Hey, there!This is kewal . I'm facing some trouble configuring datasource in the JBoss WildFly 10.1.0.While trying to configure XADatasource, it is showing : Failed to create JDBC connection with the following response : Unexpected HTTP response: 500 Request { "address" => [ ("subsystem" => "datasources"), ("xa-data-source" => "abc") ], "operation" => "test-connection-in-pool" } Response Internal Server Error { "outcome" => "failed", "failure-description" => "WFLYJCA0040: failed to invoke operation: WFLYJCA0047: Connection is not valid", "rolled-back" => true, "response-headers" => {"process-state" => "reload-required"} } please could anyone help me sorting out this problem?

tags: java

Comments

User Image
lucky3827

Newbie

Joined : 20 Apr, 2017

Points : 110

Threads: 15

Posts: 72

Re: Configuring XA Datasource in Jboss WildFly server

Reply Date : 21 Mar, 2017

I am also getting the same exception..

User Image
G3879

Newbie

Joined : 20 Apr, 2017

Points : 100

Threads: 0

Posts: 3

Re: Configuring XA Datasource in Jboss WildFly server

Reply Date : 21 Mar, 2017

i am also getting same problem, but right now i'm fixed that problem. So i want give solution for that problem,i think it is helpful for u.....when u getting this problem Go to this location E:\wildfly-10.1.0.Final\standalone\configuration and find the standlone.xml file and open the file....findout the mysql specific configuration see below the configuration just for identification perpose....Only paste the one line of code/tag to fixed this problem... ..................................................................................... com.mysql.jdbc.jdbc2.optional.MysqlXADataSource ...................................................................................... the above datasource-class tag paste in specific position like below............ Once paste the datasource-class in the standlone.xml save the file and restart your server...then test your connection.... [$xml] localhost test mysql root root true org.h2.jdbcx.JdbcDataSource com.mysql.jdbc.Driver com.mysql.jdbc.jdbc2.optional.MysqlXADataSource [:$xml]

User Image
G3879

Newbie

Joined : 20 Apr, 2017

Points : 100

Threads: 0

Posts: 3

Re: Configuring XA Datasource in Jboss WildFly server

Reply Date : 21 Mar, 2017

com.mysql.jdbc.jdbc2.optional.MysqlXADataSource

User Image
G3879

Newbie

Joined : 20 Apr, 2017

Points : 100

Threads: 0

Posts: 3

Re: Configuring XA Datasource in Jboss WildFly server

Reply Date : 21 Mar, 2017

i am also getting same problem, but right now i'm fixed that problem. So i want give solution for that problem,i think it is helpful for u.....when u getting this problem Go to this location E:\wildfly-10.1.0.Final\standalone\configuration and find the standlone.xml file and open the file....findout the mysql specific configuration see below the configuration just for identification perpose....Only paste the one line of code/tag to fixed this problem... ..................................................................................... com.mysql.jdbc.jdbc2.optional.MysqlXADataSource ...................................................................................... the above datasource-class tag paste in specific position like below............ Once paste the datasource-class in the standlone.xml save the file and restart your server...then test your connection.... [$xml] localhost test mysql root root true org.h2.jdbcx.JdbcDataSource com.mysql.jdbc.Driver com.mysql.jdbc.jdbc2.optional.MysqlXADataSource [:$xml]

Load More

No More Comments